In order to use the BUX app, there are some minimum requirements for your phone:

  • For iPhone your iOS version needs to be at least 9.0. Therefore, the BUX app will only run on an iPhone 4 and up (i.e., 4, 4S, 5, 5C, 5S, 6 and 6 Plus).
  • For Android you need at least Android 4.5 Lollipo
  • Finally, please make sure you have a good working internet connection: 3G, 4G or Wi-Fi connection is recommended.

If you have any further questions in regards to this, please feel free to contact us via email at BUX Support.